Shellshock, Bug Terbaru Pada Linux dan Mac OSX 2014

ETHIC.NINJA — Seperti yang telah dipublikasikan di Vulnerability Summary for CVE-2014-6271 , bahwa Shellshock atau Bug pada Bash memiliki tingkat resiko yang tinggi berpotensi pengambil alihan sistem oleh hacker kepada target.

Bug ini terdapat pada Bash pada sistem Unix seperti Linux dan Mac OSX, padahal seperti yang kita tahu 2 OS ini banyak digunakan oleh pengguna, apalagi para penyedia hostingan, khususnya di Indonesia hampir semuanya menggunakan sistem operasi Linux.

Apa itu Bash?

Bash adalah bagian dari software yang menerjemahkan perintah dari ketikan user untuk diproses oleh komputer. Bash memiliki banyak command yang siap untuk dijalankan oleh komputer. Bash dapat anda jalankan pada terminal, saat ini biasanya bash dijalankan oleh GUI software jadi jarang digunakan secara langsung oleh user.

Lantas aspek apa saja yang dapat menjadi sasaran serangan? 

  1. Komputer-komputer dengan OS Linux dan Mac OSX yang belum dilakukan penambalan / unpatched computer 
  2. Web servers, mengingat di dalamnya banyak data public, sangat masuk akal jika web server dijadikan sasaran utama hacker
  3. Router dan sejenisnya yang menggunakan sistem UNIX juga dapat dijadikan sasaran serangan

 Bagaimana mengetahui jika bash anda terdapat bug ini?

Anda dapat melakukan testing pada terminal anda, ketikkan :

env x='() { :;}; echo hello’ bash -c ‘echo ninja’

Jika anda mendapat balasan dari sistem : hello ninja

Maka sistem anda memiliki vulnerable ini. Jika tidak maka akan mendapatkan pesan :

bash: warning: x: ignoring function definition attempt bash: error importing function definition for `x’ hello

Bagaimana saya memperbaiki/menambal/patching bug ini?

Unuk sistem Linux sudah banyak yang mengeluarkan patch ini, ikuti petunjuknya disini. Untuk Mac OSX belum ada namun anda dapat melakukan upgrade manual bash, ikuti petunjuknya disini.

Leave a Reply

Your email address will not be published. Required fields are marked *